<!DOCTYPE html><html><head><meta charSet="utf-8"/><meta name="viewport" content="width=device-width"/><title>Technical Posts Overview and Roundup</title><meta name="description" content="While I write about various things I find interesting, specific technical topics tend to be recurring themes. So, as both a way to organize the posts for a future long-form synthesis and for the influx of new subscribers, an overview and roundup of posts I&#x27;ve written over the last two years.

On Docker. One of my areas where I&#x27;ve gone deep technically. Docker is interesting because it solves three different problems – (1) a runtime to execute workloads in a distributed system, (2) a packaging fo"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@mattrickard"/><meta name="twitter:creator" content="@mattrickard"/><meta property="og:title" content="Technical Posts Overview and Roundup"/><meta property="og:description" content="While I write about various things I find interesting, specific technical topics tend to be recurring themes. So, as both a way to organize the posts for a future long-form synthesis and for the influx of new subscribers, an overview and roundup of posts I&#x27;ve written over the last two years.

On Docker. One of my areas where I&#x27;ve gone deep technically. Docker is interesting because it solves three different problems – (1) a runtime to execute workloads in a distributed system, (2) a packaging fo"/><meta property="og:url" content="https://matt-rickard.com"/><meta property="og:image" content="https://matt-rickard.com/api/og?title=Technical%20Posts%20Overview%20and%20Roundup"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Matt Rickard"/><link rel="canonical" href="https://matt-rickard.com/technical-posts-roundup"/><link rel="icon" href="/favicon.ico"/><link rel="alternate" type="application/rss+xml" title="Matt Rickard" href="/rss/"/><meta name="robots" content="index,follow"/><meta property="og:type" content="article"/><meta property="article:published_time" content="2022-11-26T06:30:17.000-08:00"/><meta property="article:author" content="Matt Rickard"/><meta name="next-head-count" content="20"/><link rel="preload" href="/_next/static/css/7e38a4daec293498.css" as="style"/><link rel="stylesheet" href="/_next/static/css/7e38a4daec293498.css" data-n-g=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-c67a75d1b6f99dc8.js"></script><script src="/_next/static/chunks/webpack-7ee66019f7f6d30f.js" defer=""></script><script src="/_next/static/chunks/framework-715a76d8b0695da7.js" defer=""></script><script src="/_next/static/chunks/main-9ac5e5ba926acb29.js" defer=""></script><script src="/_next/static/chunks/pages/_app-f7f0bbf0d9b77417.js" defer=""></script><script src="/_next/static/chunks/373-1d8a706b57ff8e77.js" defer=""></script><script src="/_next/static/chunks/pages/%5Bslug%5D-a69b9739c4e1111a.js" defer=""></script><script src="/_next/static/fbaxpcl2LfatRiMASARkW/_buildManifest.js" defer=""></script><script src="/_next/static/fbaxpcl2LfatRiMASARkW/_ssgManifest.js" defer=""></script></head><body><div id="__next"><script>!function(){try{var d=document.documentElement,c=d.classList;c.remove('light','dark');var e=localStorage.getItem('theme');if('system'===e||(!e&&true)){var t='(prefers-color-scheme: dark)',m=window.matchMedia(t);if(m.media!==t||m.matches){d.style.colorScheme = 'dark';c.add('dark')}else{d.style.colorScheme = 'light';c.add('light')}}else if(e){c.add(e|| '')}if(e==='light'||e==='dark')d.style.colorScheme=e}catch(e){}}()</script><div class="p-3 justify-center flex m-auto "><div class=" max-w-[720px] w-full"><h1 class="text-lg dark:text-blue-350 text-blue-500 pb-3"><div class="hidden sm:flex items-center space-x-6"><div class="font-bold flex-grow text-xl sm:block flex items-center"><a href="/">Matt Rickard</a></div><div class="text-right text-base"><a href="/about">About</a></div><div class="text-right text-base"><a href="/archive">Posts</a></div><div class="text-right text-base"><a href="/subscribe">Subscribe</a></div><div class="flex space-x-6"><div class="w-8 h-8 cursor-pointer flex items-center justify-center"><svg xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24" height="16px" width="16px"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path></svg></div><div class="w-8 h-8 cursor-pointer flex items-center justify-center"><svg fill="currentColor" xmlns="http://www.w3.org/2000/svg" viewBox="0 -2 24 24" height="16px" width="16px"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></div><div class="w-8 h-8 cursor-pointer flex items-center justify-center"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20" fill="currentColor" aria-hidden="true" width="16px" height="16px"><path fill-rule="evenodd" d="M10 2a1 1 0 011 1v1a1 1 0 11-2 0V3a1 1 0 011-1zm4 8a4 4 0 11-8 0 4 4 0 018 0zm-.464 4.95l.707.707a1 1 0 001.414-1.414l-.707-.707a1 1 0 00-1.414 1.414zm2.12-10.607a1 1 0 010 1.414l-.706.707a1 1 0 11-1.414-1.414l.707-.707a1 1 0 011.414 0zM17 11a1 1 0 100-2h-1a1 1 0 100 2h1zm-7 4a1 1 0 011 1v1a1 1 0 11-2 0v-1a1 1 0 011-1zM5.05 6.464A1 1 0 106.465 5.05l-.708-.707a1 1 0 00-1.414 1.414l.707.707zm1.414 8.486l-.707.707a1 1 0 01-1.414-1.414l.707-.707a1 1 0 011.414 1.414zM4 11a1 1 0 100-2H3a1 1 0 000 2h1z" clip-rule="evenodd"></path></svg></div></div></div><div class="sm:hidden block items-center"><div class="flex items-center w-full pb-3 pr-3"><div class="flex-grow text-xl sm:block flex items-center font-bold min-w-fit"><a href="/">Matt Rickard</a></div><div class="flex space-x-6"><div class="w-8 h-8 cursor-pointer flex items-center justify-center"><svg xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24" height="16px" width="16px"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"></path></svg></div><div class="w-8 h-8 cursor-pointer flex items-center justify-center"><svg fill="currentColor" xmlns="http://www.w3.org/2000/svg" viewBox="0 -2 24 24" height="16px" width="16px"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"></path></svg></div><div class="w-8 h-8 cursor-pointer flex items-center justify-center"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20" fill="currentColor" aria-hidden="true" width="16px" height="16px"><path fill-rule="evenodd" d="M10 2a1 1 0 011 1v1a1 1 0 11-2 0V3a1 1 0 011-1zm4 8a4 4 0 11-8 0 4 4 0 018 0zm-.464 4.95l.707.707a1 1 0 001.414-1.414l-.707-.707a1 1 0 00-1.414 1.414zm2.12-10.607a1 1 0 010 1.414l-.706.707a1 1 0 11-1.414-1.414l.707-.707a1 1 0 011.414 0zM17 11a1 1 0 100-2h-1a1 1 0 100 2h1zm-7 4a1 1 0 011 1v1a1 1 0 11-2 0v-1a1 1 0 011-1zM5.05 6.464A1 1 0 106.465 5.05l-.708-.707a1 1 0 00-1.414 1.414l.707.707zm1.414 8.486l-.707.707a1 1 0 01-1.414-1.414l.707-.707a1 1 0 011.414 1.414zM4 11a1 1 0 100-2H3a1 1 0 000 2h1z" clip-rule="evenodd"></path></svg></div></div></div><div class="flex w-full space-x-6"><div><a href="/about">About</a></div><div><a href="/archive">Posts</a></div><div><a href="/subscribe">Subscribe</a></div></div></div></h1><span class="prose dark:prose-invert"><div class="border-t-2 py-3 dark:border-neutral-800"><h1 class="dark:text-neutral-200 font-bold text-xl mb-0 not-prose"><a href="/technical-posts-roundup">Technical Posts Overview and Roundup</a></h1><div class="prose-sm">Nov 26, 2022</div><article><div><p>While I write about various things I find interesting, specific technical topics tend to be recurring themes. So, as both a way to organize the posts for a future long-form synthesis and for the influx of new subscribers, an overview and roundup of posts I've written over the last two years. </p><p><strong>On Docker. </strong>One of my areas where I've gone deep technically. Docker is interesting because it solves three different problems – (1) a runtime to execute workloads in a distributed system, (2) a packaging format for production artifacts, and (3) a developer tool. </p><ul><li><a href="https://matt-rickard.com/non-obvious-docker-uses">Non-obvious Docker uses</a></li><li><a href="https://matt-rickard.com/building-a-new-dockerfile-frontend">An alternative to the Dockerfile format</a> (<a href="https://github.com/r2d4/mockerfile">code</a>)</li><li><a href="https://matt-rickard.com/docker-merge/">Docker Merge</a> (<a href="https://github.com/r2d4/docker-merge">code</a>)</li><li><a href="https://matt-rickard.com/make-docker">Docker as a generalized build system</a> or <a href="https://matt-rickard.com/docker-is-a-compiler">Docker as a compiler</a></li><li><a href="https://matt-rickard.com/different-types-of-containers">Different types of software containers</a></li><li><a href="https://matt-rickard.com/docker-desktop-alternatives">An Overview of Docker Desktop Alternatives</a></li></ul><p><strong>On cloud strategy. </strong>This is only the iceberg of cloud penetration. There are significant workloads to be lifted from on-premise data centers and net-new use cases. However, all types of dynamics are at play – cost advantages, distribution channels, and developer experience. </p><ul><li><a href="https://matt-rickard.com/aws-is-not-a-dumb-pipe/">AWS is Not a Dumb Pipe</a></li><li><a href="https://matt-rickard.com/why-did-heroku-fail/">Why Did Heroku Fail?</a></li><li><a href="https://matt-rickard.com/low-end-aws-disruption">Low-end AWS Disruption</a></li><li><a href="https://matt-rickard.com/cloud-cost-era">The Cloud Cost Era</a></li><li><a href="https://matt-rickard.com/the-problems-with-cloud-prem">The Problems with "Cloud-Prem"</a></li><li><a href="https://matt-rickard.com/saas-isolation-patterns">SaaS Isolation Patterns</a></li><li><a href="https://matt-rickard.com/the-cloud-tax">The Cloud Tax Implications</a></li><li><a href="https://matt-rickard.com/cloud-repatriation-or-not">Cloud Repatriation or Not?</a></li><li><a href="https://matt-rickard.com/cloud-native-localhost">Cloud Native Localhost</a></li><li><a href="https://matt-rickard.com/dont-be-scared-of-vendor-lock-in">Don't Be Scared of Cloud Lock-in</a></li><li><a href="https://matt-rickard.com/the-quick-uptake-of-arm-on-cloud">The Quick Uptake of ARM on Cloud</a></li><li><a href="https://matt-rickard.com/iac-strength-or-weakness-for-cloud-providers">IaC: Strength or Weakness for Cloud Providers?</a></li></ul><p><strong>On version control, package management, and other software workflows. </strong>Shipping code has never been more of a coordination problem. How do you share and reuse code quickly and efficiently? So much happens between a developer writing code and that code making it to production.  </p><ul><li><a href="https://matt-rickard.com/what-comes-after-git/">What Comes After Git</a></li><li><a href="https://matt-rickard.com/a-universal-package-manager">A Universal Package Manager</a></li><li><a href="https://matt-rickard.com/githubs-missing-package-manager">GitHub's Missing Package Manager</a></li><li>History of Version Control Systems: <a href="https://matt-rickard.com/history-of-version-control-part-1">Part 1</a>, <a href="https://matt-rickard.com/history-of-version-control-part-2">Part 2</a>, and <a href="https://matt-rickard.com/history-of-version-control-systems-part-3">Part 3</a></li><li><a href="https://matt-rickard.com/package-managers-productivity">Package Managers and Developer Productivity</a></li><li><a href="https://matt-rickard.com/social-coding">Is GitHub a Social Network?</a></li><li><a href="https://matt-rickard.com/the-end-of-ci">The End of CI</a></li><li><a href="https://matt-rickard.com/your-integration-tests-are-too-long">Your Integration Tests are Too Long</a></li><li><a href="https://matt-rickard.com/thoughts-on-github-actions">Thoughts on GitHub Actions</a></li><li><a href="https://matt-rickard.com/github-isnt-about-code">GitHub Isn't About Code</a></li><li><a href="https://matt-rickard.com/devops-wedge-code-or-issues">Code or Issues in DevOps Platform(s)?</a></li></ul><p><strong>On WebAssembly. </strong>WebAssembly can be useful on the client – as a runtime that opens up the web to other LLVM-based languages. It can also be useful on the server – as a granular runtime that is more lightweight than a container. </p><ul><li><a href="https://matt-rickard.com/what-is-webassembly">What is WebAssembly?</a></li><li><a href="https://matt-rickard.com/extending-applications-with-webassembly">Extending Applications with WebAssembly</a></li><li><a href="https://matt-rickard.com/wasi-vs-wasm">WASI vs. WASM</a></li><li><a href="https://matt-rickard.com/serverside-vs-clientside-wasm">Serverside, or Clientside WASM?</a></li><li><a href="https://matt-rickard.com/towards-granular-compute">Towards Granular Compute</a></li><li><a href="https://matt-rickard.com/isolates-and-containers">Will v8 Isolates Coexist With Containers?</a></li><li><a href="https://matt-rickard.com/write-once-run-anywhere">The Promise of Write Once, Run Anywhere</a></li><li><a href="https://matt-rickard.com/java-py-script">{Java,Py}Script</a></li><li><a href="https://matt-rickard.com/user-generated-code">UGC: User-Generated Code</a></li></ul><p><strong>On infrastructure-as-code. </strong>As cloud standardizes APIs, we can start to treat infrastructure as code. Of course, this opens up entirely new workflows – embedding infrastructure into CI, easy replication of entire stacks for preview environments, staging environments, reproducible infrastructure, and more. Still, a lot to figure out.</p><ul><li><a href="https://matt-rickard.com/infrastructure-defined-software">Infrastructure Defined Software</a></li><li><a href="https://matt-rickard.com/why-typescript-for-infrastructure">Why TypeScript for Infrastructure?</a></li><li><a href="https://matt-rickard.com/infra-as-sql">Infrastructure as SQL</a></li><li><a href="https://matt-rickard.com/request-for-project-typescript-docker-construct">Request for Product: Typescript Docker Construct</a></li></ul><p><strong>On software configuration. </strong>Configuring software is changing due to clouds, runtimes (Docker and WebAssembly), and infrastructure-as-code. </p><ul><li><a href="https://matt-rickard.com/virgo-lang">Virgo: a Graph-based Configuration Language</a></li><li><a href="https://matt-rickard.com/heptagon-of-configuration">The Heptagon of Configuration</a></li><li><a href="https://matt-rickard.com/why-do-configuration-changes-cause-outages">Why Do Configuration Changes Cause Outages?</a></li><li><a href="https://matt-rickard.com/advanced-configuration-languages-are-wrong">Every Sufficiently Advanced Configuration Language is Wrong</a></li><li><a href="https://matt-rickard.com/configuration-to-code">Configuration-to-Code</a></li><li><a href="https://matt-rickard.com/so-easy-you-could-run-it-yourself">So Easy You Could Run It Yourself</a></li></ul><p><strong>On Kubernetes. </strong>A complex yet essential part of the software stack. I worked on Kubernetes open-source at Google, so I'm biased. But I like to think that I provide a nuanced view of it. </p><ul><li><a href="https://matt-rickard.com/dont-use-kubernetes-yet">Don't Use Kubernetes, Yet</a></li><li><a href="https://matt-rickard.com/kubernetes-in-the-data-stack">Kubernetes in the Data Stack</a></li><li><a href="https://matt-rickard.com/kubernetes-maximalism">Kubernetes Maximalism</a></li><li><a href="https://matt-rickard.com/fast-kubernetes-development">Fast Kubernetes Development with File Sync and Smart Rebuilds</a></li></ul><p></p></div></article></div><div class="flex justify-center m-6"><div class="not-prose"><div class="text-center">Subscribe for daily posts on startups &amp; engineering.</div><form class="mt-8 sm:flex items-center"><input id="email-address" name="email" type="email" autoComplete="email" required="" class="w-full px-5 py-3 placeholder-gray-500 dark:bg-black focus:ring-blue-500 focus:border-blue-500 border-blue-500 dark:focus:ring-blue-350 dark:focus:border-blue-350 dark:border-blue-350 border rounded-md sm:max-w-xs" placeholder="larry@google.com"/><div class="mt-3 rounded-md shadow sm:mt-0 sm:ml-3 sm:flex-shrink-0"><button type="submit" class="w-full flex items-center justify-center px-5 py-3 border border-transparent text-base font-medium rounded-md text-white bg-blue-500 dark:bg-blue-350 dark:text-black hover:bg-blue-700 dark:hover:bg-blue-500 focus:outline-none focus:ring-2 focus:ring-offset-2 focus:ring-blue-500 dark:focus:ring-blue-350">Subscribe</button></div></form><div class="flex justify-center hidden"><div class="hidden"><p class=" dark:text-green-300 text-green-600"></p></div><div class="hidden"><p class=" dark:text-red-300 text-red-600"></p></div></div></div></div></span></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>